Georgia Dubs
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Turn Signals

5 posters

Go down

Turn Signals Empty Turn Signals

Post by peregrine67 Wed Jun 30, 2010 8:09 pm

Somebody refresh my memory, please. It's been a while.

I'm trouble shooting my turn signals. All the running lights work when I turn the lights on. But when I turn the signals on I get a really fast relay click, 5-10 clicks per second, and no signal lights.

bulbs?
relay?
something else?
peregrine67
peregrine67
Out of Control Dubber

Number of posts : 1343
Age : 55
Location : Lilburn, Ga
Registration date : 2010-01-27

http://freephilosophicaldiscussions.blogspot.com/

Back to top Go down

Turn Signals Empty Re: Turn Signals

Post by zabo Thu Jul 01, 2010 9:16 am

id check your grounds before you get too far. also double check all the bulbs look good and are in correctly
zabo
zabo
Dub God

Number of posts : 2260
Location : decatur
Registration date : 2008-08-04

http://www.trustzabo.com

Back to top Go down

Turn Signals Empty Re: Turn Signals

Post by peregrine67 Thu Jul 01, 2010 9:33 am

zabo wrote:id check your grounds before you get too far. also double check all the bulbs look good and are in correctly
Each signal housing should have it's own ground, correct?
If the running lights work doesn't that imply that the housing is grounded properly?
I'll check all the bulbs tonight.
peregrine67
peregrine67
Out of Control Dubber

Number of posts : 1343
Age : 55
Location : Lilburn, Ga
Registration date : 2010-01-27

http://freephilosophicaldiscussions.blogspot.com/

Back to top Go down

Turn Signals Empty Re: Turn Signals

Post by bumblebuggy Thu Jul 01, 2010 11:18 am

I'd guess relay but I'd start with replacing the bulbs on one side. Cleaning the grounds couldn't hurt either.
bumblebuggy
bumblebuggy
Out of Control Dubber

Number of posts : 1921
Location : McDonough
Registration date : 2008-07-24

Back to top Go down

Turn Signals Empty Re: Turn Signals

Post by peregrine67 Thu Jul 01, 2010 12:11 pm

I'll probably disassemble more than I have to in order to figure it out but no worries. People will just have to get used to hand signals for a few days.
peregrine67
peregrine67
Out of Control Dubber

Number of posts : 1343
Age : 55
Location : Lilburn, Ga
Registration date : 2010-01-27

http://freephilosophicaldiscussions.blogspot.com/

Back to top Go down

Turn Signals Empty Re: Turn Signals

Post by 68buggirrl Thu Jul 01, 2010 3:37 pm

^ haha thats what i do for my Right turns.

I had the same issue on my 68 beetle. I cleaned the ground on both sides and replaced the relay.
Only left works. But when all lights are on they all work. Turns on right just doesnt. So idk. lol

I would def clean them up sand the terminals too.
68buggirrl
68buggirrl
Dub Nut

Number of posts : 301
Age : 32
Location : Lakewood, CA
Registration date : 2010-03-20

https://www.facebook.com/?ref=home#!/bimmergirrl

Back to top Go down

Turn Signals Empty Re: Turn Signals

Post by ASBug Thu Jul 01, 2010 4:54 pm

peregrine67 wrote:I'll probably disassemble more than I have to in order to figure it out but no worries. People will just have to get used to hand signals for a few days.
I was using had signals when the ASBug's signals were down.
It was scarry how many people would wave back when I was signalling a left hand turn.
My RHD's front socket is corroded for the right turn signal and I have been tempted to do a hand signal, but I have no Idea how to from the other side of the car....
LOL
KC
ASBug
ASBug
Dub God

Number of posts : 2185
Age : 50
Location : Varnell, GA
Registration date : 2009-01-12

Back to top Go down

Turn Signals Empty Re: Turn Signals

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum