i have 2 problems

View previous topic View next topic Go down

i have 2 problems

Post by buggin70 on Wed Nov 17, 2010 9:59 pm

well to start im pretty sure my clutch is slipping really bad i just want yalls opinions
rpms really high (sound high i dont have a tach) and i go nowhere
and it wont do up a hill i have to downshift to third when before i didnt
and just a all around loss of power

problem two is i think my rear shocks need to be replaced
what kind should i get?
currently im lowered 2 outer clicks

avatar
buggin70
Out of Control Dubber

Number of posts : 1956
Age : 25
Location : canton
Registration date : 2009-09-26

View user profile

Back to top Go down

Re: i have 2 problems

Post by buggin70 on Wed Nov 17, 2010 10:00 pm

and would my flywheel have to be reserfaced or get a new one also?
avatar
buggin70
Out of Control Dubber

Number of posts : 1956
Age : 25
Location : canton
Registration date : 2009-09-26

View user profile

Back to top Go down

Re: i have 2 problems

Post by buggin70 on Thu Nov 18, 2010 12:00 am

rabbit


Last edited by buggin70 on Thu Nov 18, 2010 12:03 pm; edited 1 time in total
avatar
buggin70
Out of Control Dubber

Number of posts : 1956
Age : 25
Location : canton
Registration date : 2009-09-26

View user profile

Back to top Go down

Re: i have 2 problems

Post by fluxcap on Thu Nov 18, 2010 4:36 am

buggin70 wrote:um guess everyone hates me and they dont wanna help?
No, we just have jobs and have to go to bed early Laughing . If you are still able to drive, I don't guess it's going to be a stripped brake drum, so it does sound like something clutch related. Are you dripping any oil possibly from around where the engine and transmission mate up? Could be your main seal or transmission is leaking and getting the clutch area slippery. Or your pressure plate may have weakened. I'm no expert on this issue, so let others chime in first, but you'll probably need to pull the engine and take a look at everything to find the problem.


_________________
eric

It's like, how much more black could this be, and the answer is none.......none more black.

1962 ragtop beetle
1966 camper bus - Bocephus
avatar
fluxcap
Dub Lieutenant General
Dub Lieutenant General

Number of posts : 3854
Location : Newnan, GA
Registration date : 2008-07-20

View user profile

Back to top Go down

Re: i have 2 problems

Post by buggin70 on Thu Nov 18, 2010 12:02 pm

true i guess i never look at the tie when i dont have school.

i forgot to mention this clutch is maybe a year old if that
but i did have to push it off forever and ride the cluch when i didnt know how to fix my car and it ran real bad

ill look for the oil
and i only have to make it to school and back on monday
then i can tear it apart and i dont have school til december first so ill have time to fix it

but anyone else feel free to chime in
avatar
buggin70
Out of Control Dubber

Number of posts : 1956
Age : 25
Location : canton
Registration date : 2009-09-26

View user profile

Back to top Go down

Re: i have 2 problems

Post by Damn-it Don on Thu Nov 18, 2010 12:10 pm

fluxcap wrote:
buggin70 wrote:um guess everyone hates me and they dont wanna help?
No, we just have jobs and have to go to bed early Laughing . If you are still able to drive, I don't guess it's going to be a stripped brake drum, so it does sound like something clutch related. Are you dripping any oil possibly from around where the engine and transmission mate up? Could be your main seal or transmission is leaking and getting the clutch area slippery. Or your pressure plate may have weakened. I'm no expert on this issue, so let others chime in first, but you'll probably need to pull the engine and take a look at everything to find the problem.


The possible culprits are pretty much in that same area- I'd pull the engine too, and see what you find. I pretty sure, when a brake drum gives out, it suddenly quits (you get an all than nothing kinda event) so i doubt it's that. All the stuff mentioned above would probably give the symptoms you have- so get out those jackstands!
avatar
Damn-it Don
Out of Control Dubber

Number of posts : 1692
Age : 49
Location : Kinda like Mayberry around here
Registration date : 2008-07-25

View user profile http://airwerxart.com

Back to top Go down

Re: i have 2 problems

Post by buggin70 on Thu Nov 18, 2010 12:14 pm

i dont wanna sound spoiled but im going to use the lift

wayyyyyyyyyyyyyyyy easier

but i do know how to do it on jack stands too ive done it pleanty of times with drew
avatar
buggin70
Out of Control Dubber

Number of posts : 1956
Age : 25
Location : canton
Registration date : 2009-09-26

View user profile

Back to top Go down

Re: i have 2 problems

Post by EngineerTEN on Fri Nov 19, 2010 9:27 am

Check that your rear brake drum hub is not worn and spinning as well. I've had that happen to me.
avatar
EngineerTEN
Dub Nut

Number of posts : 358
Age : 42
Location : Douglasville, GA
Registration date : 2008-07-29

View user profile

Back to top Go down

Re: i have 2 problems

Post by Bugman114 on Fri Nov 19, 2010 11:05 am

if the clutch is indeed slipping, you will need a new flywheel if you keep driving it, because if it wears all the way down to the rivets or the metal, your screwed. also, if you overheat it to bad, you will also need a new flywheel. but yeah, check for oil, if its oil'y replace the flywheel o ring and rear seal
avatar
Bugman114
Dub God

Number of posts : 2460
Age : 28
Location : Ellenwood, GA
Registration date : 2008-08-09

View user profile

Back to top Go down

Re: i have 2 problems

Post by buggin70 on Fri Nov 19, 2010 1:36 pm

i looked and there is no oil
ill go out in a second and look at the drums

and this sucks cause its my daily. i only drive it when i absolutely have to now
avatar
buggin70
Out of Control Dubber

Number of posts : 1956
Age : 25
Location : canton
Registration date : 2009-09-26

View user profile

Back to top Go down

Re: i have 2 problems

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum